My parents don't much care for Vista, so after I got their XP machine up and running, they gave me the Dell Dimension E520 they'd bought and were hardly using. I added 2Gb of RAM and a new video card to it with no problems, but when I tried to add a second hard drive for ubuntu, I ran into a snag.

File this under User Interface design flaws

Normally I build my own computers, but when someone offers you a free 8-month old 3Ghz Dell when your dual 800Mhz Pentium III machine has lost yet another hard drive, you just don't say, "no thanks".

So the memory and video card upgrades were a breeze. Dell gives you tons of empty space in their machines and with all the advances since 2000, there are far fewer cables to deal with. Dell even gives you some nifty hard drive rails that remove the need to screw the HD into place (pardon the glare). This makes adding a new HD a complete breeze. There are even clips for the cable along the case to keep it under control and out of the way.

Now, take a look at this image from the installation manual:

See that little square to the right of the SATA cable connector? Not the rectangle in the grey circle, the square between them. It's a HOLE in the back of the drive.

A HOLE.

I can only assume it's there to make sure people connect the cable to the back of the drive correctly. Which in an of itself is a noble gesture on the part of the manufacturer. Anyone new to adding a hard drive could be driven quickly insane when it doesn't dawn on them that a cable could be on backwards.

So here's the problem:

to which I replied

I could install the HD in the cage at the top of the box, under the DVD drive, but that'll be more trouble than it's worth. I guess I'll head back to Fry's and pick up a normal SATA cable tomorrow.

Or I'll take my bow saw to the cable that I have now.